Browser requirements for the Genesys Cloud embedded clients


Note: This article applies to Genesys Cloud Embeddable Framework, Genesys Cloud for Chrome, Genesys Cloud for Firefox, Genesys Cloud for Salesforce, and Genesys Cloud for Zendesk.

Your browser running the client must be the latest version of Chrome, Firefox, or Microsoft Edge. For information about Internet Explorer, see Deprecation: Internet Explorer support for the Genesys Cloud embedded clients.

To use WebRTC phones, turn off pop-up blocker in your browser. 

Note: Microsoft Edge does not support WebRTC phones or screen share.

Other browser requirements are specific to Genesys Cloud for Salesforce and Genesys Cloud for Zendesk.

The following content applies to Genesys Cloud for Salesforce.

In addition to client’s browser requirements, Salesforce also has its own browser requirements. For more information, see Recommendations and Requirements for All Browsers in the Salesforce documentation.

The following content applies to Genesys Cloud for Zendesk.

In addition to the client’s browser requirements, Zendesk has its own browser requirements. For more information, see Zendesk Support system requirements in the Zendesk documentation.

For more information about the integrations, see About the Genesys Cloud browser extensionsAbout Genesys Cloud Embeddable Framework, About Genesys Cloud for Salesforce, and About Genesys Cloud for Zendesk.