Troubleshoot screen share

On January 27, 2025, Genesys will no longer support screen share functions for chat and voice in Genesys Cloud. For more information, see Deprecation: Legacy co-browse and screen share.

Problem

Sharers receive an error, or nothing happens, when they try to share a screen.

Solutions

Try the following solutions:

  • If the sharer is using Chrome and version 71 or older, then uninstall and reinstall the Chrome extension.
  • Confirm that users do not have a local firewall enabled, such as the Windows firewall.

Problem

Sharers think that they are sharing their screen, but the agent does not see the shared screen.

Causes

  • Sharers are using Firefox and accidentally clicked away from the screen picker window.
  • The screen share request timed out or the agent canceled it, and sharers did not notice the timeout messages because they were choosing a screen to share.

Solutions

  • Help sharers locate the Firefox screen share picker and choose a screen to share.
  • Communicate to the sharer that the screen share request timed out or was canceled.

Problem

Chrome incognito mode does not recognize the screen share extension.

Solution

Tell sharers to switch to a non-incognito Chrome window or update Chrome to version 72 or newer. Chrome versions 71 and older do not support incognito mode with screen share.


Problem

The screen picker covers the sharer’s chat window, so sharers do not see messages from agents.

Cause

If sharers are using Chrome for Windows, then the screen picker overlays the web chat window, and sharers cannot chat with the agent until sharers close the screen picker.

Solution

Before starting a screen share session, agents can tell sharers to expand their web chat windows.